Windows 10 Creators Update BSOD - "SYSTEM SERVICE EXCEPTION - atikmdag.sys" when installing driver for A8 9600 APU w/ Radeon R7

Hello Everyone

 

I just built a new PC:

CPU : A8 9600 APU (AM4 socket - AMD P/N AD9600AGABCBX)

Motherboard : Gigabyte A320M-HD2

Memory : 1 x 8GB Gloway DDR4 2400 Mhz

HDD: 1x Toshiba 120GB SSD ; 1x HGST 500GB HDD

 

I assembled it myself and it booted up and ran. I installed Windows 10 on it and was able to set up everything. Windows automatically installed drivers for the APU's graphics card (Radeon R7), and the chipset drivers I downloaded and installed from the AMD support website.

 

After everything was up and running, I used the PC for a bit - some web surfing in chrome, watching 1080p videos on YouTube etc, which was handled by the APU with ease.

Since I installed Windows 10 from an older ISO from earlier this year, it was sans the creators update - windows update automatically downloaded the creators update and I rebooted the system to apply it - after rebooting, the installation started, and there was a message that the computer may restart several times during the installation - it did begin to restart during the installation.

 

After one of the restarts, there was a BSOD - I could not take a photo of what the error code was - but the system restarted itself and the update did complete eventually.

 

Now, I was back in the windows desktop again, but strangely Windows uninstalled the graphics drivers of the card after the update - the video card appeared as "Microsoft Basic Display Adapter" in device manager.

 

I tried to initiate the driver installation from the device manager (by right clicking ---> Update driver ---> search automatically for updated driver), and it did start to install the driver, but I was met with a BSOD in the middle of the install - "Stop Code: SYSTEM SERVICE EXCEPTION; What Failed : atikmdag.sys"

 

After the reboot, the video card still appeared as "Microsoft Basic Display Adapter" and any attempt to update the driver would cause the BSOD.

I downloaded and tried installing the driver from the AMD support website (Crimson ReLive Edition version 17.7.2 dated 7/27/2017), but halfway during the install process I got the BSOD with the same stop code and atikmdag.sys error

 

My hunch was that something went wrong during the creators update installation (as there was a BSOD during the install) - so I downloaded a new ISO with the creators update preinstalled from the Microsoft website and re-installed windows.

 

But I get the same BSOD as before on the fresh windows installation (when trying to install the driver from Device manager and using the AMD installer)

 

What could be the problem? The PC was working fine before the creators update.

 

Regards