Trouble with online players (and general graphics delays)

Hi,

 

First off, I apologise for not being too technical, so some of my terms will be a little basic.

 

I recently purchased a new computer which came with the AMD Radeon R7 graphics - and I've had a series of issues relating to graphic/display - and having tried various things out have had no joy.

 

I am unable to view some players, especially Sky GO (this 1 I have worked with Sky for 3 weeks, and they have concluded that I need to speak to manufacturer/graphics provider)

Additionally, when a page loads up, I catch a very brief glance of the page, then it loads up - which means any slight change appears to have a lag involved. (N.B I am using Internet Explorer 11 for these (Sky GO doesn't support anything else.) The lag problem isn't just internet based, most programs seem to have this little display lag.

 

I have very little else on the computer currently, and even before I updated drivers, had no joy. I couldn't see any prior question about this, so I'm hoping someone might be able to offer a suggestion, or is R7 not compatible with players (my previous computer was around 10 years old, but was able to run these.)

 

Thanks,


Peter

 

--

 

System Description

 

AMD Graphic card = I'm not 100% how to put this - In the settings it says "AMD Radeon(TM) R7 Graphics (Primary)" which is also the chipset. There are loads of other pieces of information, but I hope that's enough - I have updated the drivers to 17.4.4

Desktop

O/S = Windows 10 (presumably 64 bit (that's what the graphic card detected)

Computer Model = Aspire TC-280 (By Acer)

Processor = AMD A10-7800 Radeon R7, 12 Compute Cores 4C+ 8G 3.50 GHz

RAM = 8GB

Monitor = S241HL (Resolution 1920 x 1080)

Motherboard - No idea how to find this ou.