Sapphire RX Vega 64 Watercooled Version, Bluescreen during driver installation

I just got my new RX Vega 64 and unfortunately it seems to be faulty.
Before sending it back I would like to share the issue in the official forums.

 

My system:
GA-Z68X-UD4-B3

2600K (no OC)
Corsair RMi750


I was runnning a Fury X and 2 970's before without any issues.
After my Vega arrived I used DDU for driver deinstallation and was about to install the new RX Vega driver from the offical download page.
When the installer is about to install the AMD display driver and recognized the display my system crashed with Bug Check String "SYSTEM_THREAD_EXCEPTION_NOT_HANDLED" in
atikmdag.sys. I repeated to process a view times and already did a fresh new installation of Windows, always result in bluescree while installing the driver.
I already tried HDMI and Displayport connection and did reset my motherboard to factory defaults.
Apart from that, when I start my computer with "Display Full Screen Logo" from motherboard BIOS, it shows some weird blue/red artifacts instead of the logo..





 

For me the card seems faulty unfortunately. Do you recommend anything more to try before returning it? I was actually really looking forward to this card and its out of stock at the moment

 

The Event Viewer tells:
"The computer has rebooted from a bugcheck.  The bugcheck was: 0x0000007e (0xffffffffc0000005, 0xfffff80182ffb401, 0xffff9f811d6ba8f8, 0xffff9f811d6ba130). A dump was saved in: C:\Windows\MEMORY.DMP. Report Id: d1cd2e08-6c21-46bf-91cc-713e2d341246."

 

The bugcheck looks like following:

==================================================

Dump File         : 082017-4296-01.dmp

Crash Time        : 20/08/2017 16:14:05

Bug Check String  : SYSTEM_THREAD_EXCEPTION_NOT_HANDLED

Bug Check Code    : 0x1000007e

Parameter 1       : ffffffff`c0000005

Parameter 2       : fffff801`82ffb401

Parameter 3       : ffff9f81`1d6ba8f8

Parameter 4       : ffff9f81`1d6ba130

Caused By Driver  : atikmdag.sys

Caused By Address : atikmdag.sys+f43d4c

File Description  :

Product Name      :

Company           :

File Version      :

Processor         : x64

Crash Address     : atikmdag.sys+16b401

Stack Address 1   :

Stack Address 2   :

Stack Address 3   :

Computer Name     :

Full Path         : C:\Windows\Minidump\082017-4296-01.dmp

Processors Count  : 8

Major Version     : 15

Minor Version     : 15063

Dump File Size    : 788.980

Dump File Time    : 20/08/2017 16:14:44

==================================================

 

Thanks in advance and have a nice day!

 

EDIT:
Is is possible that the issue is related to PCI.E 2.0 on my board?