S7150 MxGPU Installation woes

Hi, hope someone can shed some light on my (S7150 install) issues.

 

Firstly, Server Specs.:

Motherboard: Supermicro X10SRH-CF BIOS Rev. 2.0a

Processor: Intel Xeon E5-2620 v4

Memory: 64MB

ESXI 6.5 (Full licence) with various Windows server and Win10 VM’s

AMD S7150

Intel 10G Dual NIC

Installed host drivers:

amdgpuv-1.05-1OEM.650.0.0.4598673.x86_64-CL1424097.vib

amdgpuv-cim-1.00-6.5.0-4598673.vib

 

Zero Clients:

Dell/Wyse P45 and P25

 

I would like to run some CAD applications from the Win 10 VM’s on the server via the Zero clients/Horizon View and have the 3D acceleration/capabilities for manipulating 3D models, rendering and surveillance.

 

I tried to follow this guide:

https://www2.ati.com/relnotes/amd_mxgpu_deploymentguide_vmware.pdf

 

I installed the card and went through the motions of enabling SR-IOV, memory mapping above 4GB (above 4G decoding), ASPM, MMIO High size etc.

I also installed the VIB drivers downloaded from the AMD drivers site. After the installation I could see 16 AMD GPU’s available for passthrough in the ESXI web client, however on passing through one of these GPU’s the VM would always fail to start (Module 'DevicePowerOn' power on failed).

Somewhere along the line all this fell apart and I could no longer boot the Server, where it hung on PCIE initiation. I had to reset the CMOS and revert back to the default settings.

 

This is where my ignorance shines through – in the guide there is mention of configuring MxGPU’s via the Vsphere client plugin, I don’t have Vsphere client other than the 6.5 web client and the Vsphere client 6.0.0 and no idea how to configure the S7150 and assign GPU’s to VM’s via said client.

 

I can revert to the default BIOS settings and successfully passthrough the card directly to one VM, however this defeats the purpose of MxGPU.

 

Default BIOS settings:

 

 

So, if someone would be so kind as to explain what BIOS settings I should have for the above motherboard, and how to install and configure a Vsphere client to assign GPU’s to VM’s, and also any VM settings, I would be most grateful! TIA...