RX 480 Driver Nightmare

Alright buckle-up folks.

 

Background:

 

Got 2x brand new RX 480 8GB cards from Asus two weeks ago. Installed one card, booted up windows, proceeded to install the latest driver and my desktop freezes, resulting in a laggy mouse and a loud beeping sound whenever I click. In order to get back into windows I have to reboot into safe mode and run DDU. Upon return to the normal windows desktop, the desktop freezes after 1-2 seconds and then loud beeping whenever I click with the mouse. At this point a hard reboot is required and I go through the motions in safe mode once again.

 

Kicker: When I remove the RX 480 and install a GTX 1070, I can get into windows and install nvidia drivers without any issues.

 

3 hours of asus tech support later, agent concludes the cards are defective and I RMA them. Asus tests the cards and concludes they're working properly and sends them back with a bios update. At this point I'm all giddy and excited I get to use the new cards. I proceed to uninstall the nvidia drivers with DDU in safe mode and  shut down. I install one of the RX 480s and boot up my PC. Upon reaching the windows desktop, the screen flashes black 3-4 times before returning to a frozen desktop. Mind you there are no other display drivers installed and no software/games of any kind (essentially a brand new PC). I'm going to sit on the phone with asus support again tonight, but as I'm at work I thought I'd reach out to the community for possible solutions to my problem.

 

Additionally: I was able to get into driver installation one time, but it froze instantly before the hardware detection phase. I thought it might be hanging, so I let it sit for 2 hours and nothing happened. A hard reboot was required and I could only access windows through safe mode. I've attempted another fresh install of windows 10, but that did not solve the problem either.

 

PC Specs:

i7-3770k

asus z77 sabertooth motherboard

16gb 8x2 RAM

EVGA Supernova 850w Gold PSU

Samsung Evo 256gb SSD

Windows 10 64-bit

 

 

If my problem isn't resolved tonight, AMD is getting these cards back and I'm buying another GTX 1070