RX 480 Crashing repeatedly in multiple games

Describe your system:

  • Graphics Card
    • ASUS ROG STRIX RX 480 8G
  • OS
    • Windows 10 64bit
  • Drivers
    • Multiple tested including 16.12.2
  • Monitor
    • ASUS VG248QE 24" @144HZ DVI and @60HZ HDMI(Tried both connections multiple times)
  • Motherboard
    • Gigabyte GA-Z87X-UD3H ATX Motherboard Socket LGA 1150
  • CPU
    • Intel Core i5 4670k Unlocked Quad Core 3.4GHZ Processor LGA1150 Haswell 6MB Cache
  • Power Supply
    • Corsair Enthusiast TX750M 750W ATX Modular Power Supply
  • RAM
    • Corsair Vengeance 8GB(2 x 4GB) 240-Pin DDR3 Model CMZ8GX3M2A1600C9B

 

 

I recently purchased this card to replace a 7950 that died out of warranty on me. I never had any troubles with the previous card and everything started as soon as I had installed the new one. I get multiple different crashes/display issues with different games.

 

 

World of Warcraft + Total War:Warhammer

 

 

These 2 both always perform the same way. The game runs for about 1-2 hours, sometimes I get a display driver crash where the screen flickers black a few times and goes back to normal but the majority of the time the whole system crashes and I have to power it off. Once the computer starts up again the crashes start happening far more frequently, at least every 15-20 minutes of gameplay. This seems to "reset" after a day and I'll get another 1-2 hours of gameplay before the crashing starts again.

 

 

The Division

 

 

The crashes in this one vary a bit, sometimes crashing after 15 minutes other times it'll last an hour. I do not get any driver crashes the game just crashes and sends me to desktop with no error messages. If I start up the game again it will crash within 5 minutes and it ends up taking Radeon Settings with it forcing me to restart to get it going again.

 

 

Homeworld: Deserts of Kharak/The Long Dark

 

 

These 2 are a bit strange in what ends up happening. Homeworld never actually crashes but there is a noticable flashing of strange circles appearing on the screen, the circles are opaque and vary in colour, if you think of the standard "you're aimed at the sun" light effect that's what they resemble but they only appear for a split second. The Long Dark has the same issue with the lights but it also suffers from the previous crashing issues where it takes the whole system with it, I barely get 5 minutes of sitting in the menu of this game before it goes.

 

 

 

I have tried multiple different driver versions, using DDU in safe mode to install drivers every time, this has had no effect. I went as far back as 16.7.1.

I made sure my motherboard BIOS were fully up to date.

I attempted undervolting the card slightly(setting the upper limits in Wattman to 1050) this had no effect either.

I tried swapping out connections using a DVI and then HDMI connection this had no effect either other than reducing the voltage buzz coming into my headphones during a game presumably due to the lowered refresh rate.

I uninstalled my anti-virus, disabled windows defender and tried installing drivers that way, still no difference.

I've tried setting Wattman to record the status of the card during these games(i think it's the histogram setting) this is a bit inconsistent but in the games where it actually does display the temperature does not appear to go above 60 degrees.

 

 

I have managed to play some games without encountering any issues but these were usually quite old games. Any help or advice would be appreciated I would prefer to avoid RMAing but at this stage I can't see any other option that doesn't involve a hammer.