Radion update attempting to install an older version

A custom dialog box appears.  The title is "AMD Software" and in the bottom of the dialog box is the phrase "Keep system up-to-date."  The left side of the dialog box is telling me that I have version 16.15.2211.  It doesn't tell me what software this version applies to, it just states the version number.  The right side shows an arrow pointing down (obviously, to download) and then states that the recommended driver is 15.7.1.  But 15.7.1 must be an earlier version as it's already telling me I currently have 16.15.2211 installed.  Why is it doing this?  Which version do I want? 

 

And, to be clear, the box makes no mention of what driver it's referring to.  See attached.  This is running on Windows Server 2012 Essentials R2.