Radeon RX 480 PowerColor Red Devil 8GB multi monitor issue win7

Specs:

Radeon Software Version

17.6.2

Radeon Software Edition

Crimson ReLive

Windows Version

Windows 7 (Service Pack 1) (64 bit)

System Memory

16 GB (1333Mhz)

CPU Type

Intel(R) Core(TM) i7-2600 CPU @ 3.40GHz

Mobo ASUS P8Z68-V PRO (Nuvoton NCT6776F)

PSU 1000W BeQuiet Dark Power Pro

Displays

Asus VE278 via HMDI

Medion MD20888 (Connected via HDMI to Displayport converter)

 

I also am currently running with Multi monitor IGPU support in my bios.

 

Already tried: Increased frequency on GPU by 4%, increased memory to 2200MHz, increased power limit to max (30%), but also tried on stock settings and with 10% more power, always the same issue. The GPU is not overheating. Its not even reaching 60 or 70 degrees celcius.

 

Since i plugged the second one, just sitting on windows screen has heavy stuttering on both screens, they run at 59Hz refresh rate, both are 1080p, Just out of blue, making squares on the screen feels like a slide show. Sometimes under some heavier load (Video, browser + Game). When i'm trying to play Warframe the Gpu just goes dark within 5 minutes, (Screen goes black, restart button does not respond, seems like gpu goes into loop of no display). I'v been already trying to lower the power input and also increasing it to the max, to 10%, overclocking it, downclocking, but nothing seems to help here, and i couldn't find anyone with this issue anywhere so far. I did full clear reinstallation couple of times already. with one screen, with both of them, and by that i mean going to safe mode, unstall hardware in dev manager, uninstall the drivers, restart, let him install hardware, restart, install drivers. Nothing helps.

 

I tried all 3 display ports, the further away from HDMI i went, the better result, but all temporary and i'm back to the square one.

Any suggestion would be nice.