Problem rolling back drivers!

Hello, why we are only allowed to roll back from 17.7.1 to 17.4.4 or other way? You guys should allow to go back to 17.6.2 or others. if is not asking to much, you could do a selection in the drivers section, so we can choose, and take of the automatic recognize drivers from the Crimson Relive.