Major problem with Radeon 17.4.3 with Windows 10 Creators Update on APU A8-7410/Radeon R5 M330

Hi everyone.
Before upgrading my notebook (HP 15-af130nl AP A8-7410 8GB RAM - Radeon R5 M330) Windows 10 x64 Creators Update today, I previously installed the new 17.4.3 Radeon rivers from AMD and everything went pretty fine (exception made for some cycling peaks in CPU frequency oscillating from 6 to 12% every second but with apparently no effect on system or apps performance - see pics below).


Screenshot (78).png

Screenshot (79).png


After I manually updated the system to Creators Update today through the official Microsoft upgrade assistant, Radeon Software manager didn't launch and Windows prompted me with the classic hardware error suggesting the correct drivers were not installed.

I did a clean install of 17.4.3 drivers that went apparently fine but after reboot caused an infinite error loop on explore.exe app causing the continuously refresh of the destktop.

I launched then the AMD uninstall utility and re-installed the previous 17.2.1 February drivers. It's now functioning back to normal.


The explorer error is reported as following

Nome registro: Application

Origine:       Application Error

Data:          25/04/2017 19:58:54

ID evento:     1000

Categoria attività:(100)

Livello:       Errore

Parole chiave: Classico

Utente:        N/D

Computer:      AntonioAMDn


Nome dell'applicazione che ha generato l'errore: explorer.exe, versione: 10.0.15063.0, timestamp: 0xa25b6083

Nome del modulo che ha generato l'errore: unknown, versione:, timestamp: 0x00000000

Codice eccezione: 0xc0000005

Offset errore 0x00000000067d36f0

ID processo che ha generato l'errore: 0x1a4c

Ora di avvio dell'applicazione che ha generato l'errore: 0x01d2bded98fb2692

Percorso dell'applicazione che ha generato l'errore: C:\WINDOWS\explorer.exe

Percorso del modulo che ha generato l'errore: unknown

ID segnalazione: fc17b660-f850-4899-8166-0084e9b19f0b

Nome completo pacchetto che ha generato l'errore:

ID applicazione relativo al pacchetto che ha generato l'errore:

XML evento:

<Event xmlns="">


    <Provider Name="Application Error" />

    <EventID Qualifiers="0">1000</EventID>




    <TimeCreated SystemTime="2017-04-25T17:58:54.705533800Z" />




    <Security />























My opinion is that maybe it's not the case, for now, to install 17.4.3 drivers on these APUs, waiting for more refined drivers in the coming weeks.