Link to latest AMDGPU-PRO driver for SLES/SLED refer to wrong file.

Link to latest AMDGPU-PRO (AMDGPU-Pro Driver Version 17.30 for SLED/SLES 12 SP2 - amdgpu-pro-17.30-465504.tar.xz) driver for SLES/SLED refer to wrong file that is suspectiously short. I was trying to unpack archive, but file format was not recognized. Can anybody from support replace this file to correct package file?