I need you to verify me that my Ryzen build is working correctly

I have these components:

 

Asrock x370 k4

R5 1600

Ati 7770 (upgrade soon)

2x8GB ram 3200mhz, currently working on 2133mhz

Win10

Ryzen balanced power plan

 

I sold my gpu to miners and now I am using ATI 7770 until rx 580 becomes available. I decided to try some older games but it them I expirianced micro (0,5s stuttering):

 

Morrowind - very often microstuttering, strange because resolution is 1280x960

Operation flashpoint: red river - microstuttering, small fps drop

Jade empire - Has slighty microstuttering/small fps drop, there is a stutter fix for the game

Metal gear rising - have stuttering/fps drop but only in action intension scenes

Mafia 2 - game was capped to 60fps, stuttering happens when fps for a second fall to 57fps

 

I tryed some with High perfomance mode same situation. For some of these games Windows Compatibility mode was necessary.

 

Also I try some more demanding:

 

Bioshock Infinite - no stuttering

Metro Last light - no stuttering, tested for 1 hour

Outlast: whistleblower - no stuttering, tested 40mn

Xcom enemy within - no stuttering, tested 2 hours

 

First I thought that is GPU Vram but than would stutter in demanding games. Could that stuttering be because Win10 doesn`t handle good old games

 

- I tested memory, everything ok.

 

test.PNG

 

- Is this normal score for this cpu? R 1600 stock - 3.4ghz, cpuz version 1x79 x64

cpu.PNG

 

 

- I changed some setting in Ryzen balanced power plan, I lowered CPU state (Minimum processor state to 5%, other option didn`t touch) like this:

ryzen.PNG

Now I see that core in idle are around 1.5ghz, previous they were at max. In load AIDA64 stress test, all values are at amx - 3.4ghz. Will this setting hurt my gaming perfomance?

 

Also some value in idle are 1511 and some are 1550. Is that normal?

 

picture.PNG