I can't upgrade my OpenGL from 1.1

I have recently upgraded my Windows 8.1 to 10 due to my Win 8 installation becoming increasingly sluggish and I figured I may as well do a clean install since I know that I am eligible for a free Win 10 upgrade.

 

I went ahead and upgraded my laptop, so far so good. I also upgraded my graphics for my dedicated card HD 8750M along with it and I currently sit on the latest driver version 17.3. However, I cannot make the MEmu emulator recognize that I have a valid OpenGL version above 1.1 and if I try to download a program that can detect my OpenGL version, it crashes upon start.

 

I am also in contact with Microsoft support about this issue, but I am wondering if it would help to downgrade to another version but then which one?