Getting the FX9590 Stable on a Gigabyte GA-990FXA-Gaming v1.0?

Hi All.

 

I've had this setup for less then a year as a stopgap while waiting for Ryzen.

 

I'm running a 1080w psu (swapped it from the 850TX I Was using before to rule that out) XFX 390x,
and a Corsair H100i watercooler with HSP fans x4 in a pushpull, on a obsidian 650d, with fans maxed out.

I've added a 90mm fan directly above the VRMS.

Crucial 1600mhz ram kit running at XMP.

 

It's only stable with turbo off and undervolted - (and believe me I've tried everything) I'm a veteran system builder with a decade of real world experience, I've built literally tens of thousands of machines and done some elaborate overclocking and water loops since the late 90's - it's the board, somehow.

I just redid the entire cooling setup and repasted everything just to be absolutely sure. Checked all the fan loops, etc etc.

 

I'm almost fully convinced it's the VRM at this point, but I feel that I should be able to run this chip with optimized defaults and touching nothing else in the cmos setup... right?

 

It's not getting particularly hot, even with cool and quiet and c6 and c1e and APM off (so stuck at 4.5~ish ghz) it idles at 27-33c or so. Under load it stays under 65c - until it locks up that is.

Any thoughts? I know this is a common issue but maybe someone will mention something I haven't tried. I've played with literally every option including nb voltage, LLC, etc etc - no matter what, the only way it's stable is if I turn turbo off entirely and lock it at 4.2ghz.

 

I would also like to add that this appears to be 100% voltage related - heat seems to make no difference at all unless every power phasing feature is turned off. It'll either lock up instantly when going into turbo, or very shortly after running any burn test. It's very reproducible.