Dedicated video card isn't working!

Hello AMD's forums.

 

I have an problem. I can't figure out what is the reason why my NEW notebook which I bought four day's ago works kinda slow for fresh system right out of store. Yes, i can scrool throught websites with small hiccups, maybe when it need's to load more information, for example when i open multiple sites at Google Chrome. But's thats a task's i thing new PC' (540€) should handle smoothly. Am I' right? Ehh...

 

I download League of Legends, CS:GO, Rocket League to test out this computer. All games runs on low setting (10-30 fps) , depending on actions and processes happening on the screen. It's disastrous performance. YES' i checked online videos. Searched for the exactly the same notebook as main. And other's can handle even more performance costly games like Battlefield 1 or GTA V.

 

So I've have an AMD Radeon™ R5 M430 Graphics (2 GB DDR3 dedicated) videocard which supposedly isn't active after all.

 

I installed all newest windows updates. Installed newest AMD drivers. I have 17.7.2 Radeon Software version, that one with ReLive.Checked if  HP Support Assistant is up to date, if there is updates to install. Also there is everything updated. Installed newest BIOS update from HP site. !!! Also tried reinstalling AMD drives by selecting my notebook specific's at their site. Also completely wiped out drivers, then reinstalled.

 

Power is set to high performance, plugged in cable,

 

One think certainly is weird af. I opened Device Manager to check if I can see my dedicated video card. Click'ed on Display adapters, only shows integrated one - AMD Radeon (TM) R5 Graphics. Also at Radeon Setting screen, where is system spec's. Hardware show's - AMD Radeon(TM) R5 Graphics (Primary/Integrated) with no clue of dedicated one.

 

I'm hopelessly searching for reasonable answer how to activated/switch or whatever called that process of switching from integrated to dedicated videocard.

 

Want answers. Thanks!