AMD ReLive not working

When ReLive first came out it was great. It worked flawlessly for a long time. I'm always hesitant to replace software that I'm already using with something new, but after a while I was convinced that ReLive would perform as needed, it didn't impact my game performance at all, and it was easy to use. So I deleted my Action software and I have been relying on ReLive ever since. Now in the past 2 or 3 months I have noticed significant lag spikes when ReLive saves a replay in the background, this has caused massive fails in game more times than I can count. For example recently I was racing against a friend who is very good, and who I am very competitive with, we are always trying to one-up each other. She started out ahead, but I caught up and I was pushing her driving to her limits, I was passing her around a corner on a winding mountain pass, and suddenly got a massive lag spike. I smashed into the rail at about 130mph, flipped over the rail, rolled down the side of the mountain, threw my controller across the room, tried to break my desk in half, kicked my chair into the kitchen, and then exited the game and turned off the replay feature.

 

I have also been having problems where it does not record the audio, or else the audio is not properly synced to the video. I was trying to record some Tekken 7 gameplay and I had to record it 3 times because there was no audio. Finally on the 3rd try I got audio but it was not synced. I had to go into my editing software and split the audio from the video, re-insert the audio, and approximately sync it as best as I could manually.

 

Now today I downloaded 17.7.2 ad I did a clean install, hoping that would fix that problems I have been having. Well of course it did not fix anything, it's worse. Now I cannot record gameplay at all. When I start a game, ReLive hides itself in the background, I cannot pull up the toolbar at all. The only thing I can do is it enable recording desktop, and start rrecording before I start the game, and if I do that it still does not record the game, all I get is a blank green screen with no picture and no audio.

 

I'm just going to shut up now because everything I said after this was basically a long rant about how pissed off I am.