after windows 10 installation when i try to install graphics card driver laptop is freezing

Hi. I have Toshiba Satellite P 50 B 11 U laptop with amd Radeon R9 M265X graphics card, intel i7 4770 HQ processor  and window 10 home x64 bit  operating system. Yesterday i installed windows 10 on my computer with my usb, to clean my hard drive and this process has finished successfully. after the installation i started to download laptop's driver. everything was going fine until when i try to install graphics card driver. when i try to do this on device menager it was actually not being shown in display adapters it was in other devices part with name "unknown device" but i knew this is my graphics card's driver so i started to download it. Downloading process finished an installation started at this point suddenly my computer stopped working. mouse pointer was not moving, keyboard was not typing anything, even capslock and numlock lights was not working i could not understand the problem at first and i thought something went wrong during windows 10 installation that's why i installed windows 10 all over again. After that, i download all the windows updates and made all recommended settings by windows 10 and started to download  drivers again, every single of them has installed successfully except amd graphics card driver. What i mentioned up absolutely happened again. There was no movement on the screen, neither mouse nor keyboard was not working. At this point i knew that the problem was about graphics card. But i am absolutely sure there is nothing wrong with my graphics card because it was perfectly working before windows 10 installation. i opened my laptop with secure mod and disabled amd graphics card on device menager. When i restart my computer it was perfectly working without external graphics card but performance was very lower than it use to be. i've looked lot's of forum, some of them are saying  it's something about hardware. Graphics card may be broken down because of over heating but i am absolutely sure it is not true since as i said before it was doing its job great before windows 10 installation. What ever this is, happened after windows 10 installation. Another aspect to this issue is i am downloading wrong driver but it is not possible because i've download the driver from amd's website and i am sure i downloaded the correct one.  And there is one more aspect about the issue which is driver is not working correctly this is a general mistake an it can effect anyone who use this drivers. in order to solve the problem i should get some older version of the driver or wait for a newer version of it. it looked more logical to me. i just want to get your ideas about what can i do to fix this. i hope you can help me, thanks for your helps, and if you need more info i am ready to give you what you need to know.