6350driver on xp install nightmare

Just bought a second hand Radeon HD 6350 dual output card and installed it on my HP7800 desktop single monitor system with DMS 59 to DVI dual output connector. Obviously only one output goes into my monitor. The desktop ran nicely on onboard intel graphics via vga cable but i thought I'd shift to a dedicated card to play some old games that I have.

Before I can decide if the 2nd hand card is functioning or not (which is one issue-how to), I obviously need to install its drivers.

Searching for drivers for 6350 for Win XP I came to this page: Desktop  that most helpfully gives two options of Catalyst Software suite of 179 and 195MB without any explanation as to which one I need to download and what the difference was; really disappointing quality of communication to a clueless person as me!

I downloaded both, extracted both and tried to install both one after the other and could not because at the end of installation I got the message, "install successful but there were warnings during the install process" The log file generated shows success every where- driver, .Net all successfully installed. However, there is no sign of this Catalyst suite in my newly installed programs, nor does it come up in the search box nor can I bring it up on right clicking the empty screen. The only place I can see it is in uninstall list of "add/remove programs" in the "control panel". I have mad 4 attempts to install it today and wasted 3 hours reading online about driver and this card, re-seating my card, checking leads etc.

My Questions pls:

1- Is there a way to find if the 6350 dual output card is functional even before installing the drivers? If I remove the VGA lead from onboard graphics and the monitor if connected only to the card then monitor doesn't kick up- it goes to sleep mode. Is this normal- should It not give some minimal 640x480 type output even before the driver installation? The fan runs though.

2- Do I need to do anything in BIOS- I have looked in it but there seem nothing relevant there.

3- I hope connecting the dual output card to only one monitor should not be a problem, but is there any order, as to which of the two splitter leads need to be connected to the monitor (I have alternated both without success).

4- Which of the two drivers/catalyst centers am I supposed to install and why is neither of them installing even to the default location?

Thanks for the help.