17.x.x Update Breaks My 144hz Monitor

Video of monitor with 17.x.x drivers


("18 May 2017" Yes I took a long time to post this )


I own a VG248QE (144hz $259)

The monitor came with an install disk for Windows 7 (which I lost anyways), but when I first plugged it in on both my old Nvidia/Intel PC and current AMD PC it automatically recognized and installed the respective drivers allowing up to 144hz @1080p.


For a while I was using Version 17.2.1 but somewhat recently I finally set it to update to 17.4.3


I chose the Clean Install option and the updater did everything as usual until my monitor and graphics card drivers uninstalled but the updater failed to install 17.4.3 and closed


I then went and installed 17.4.3 from the website (yes with matching GPU) and upon restarting my computer both monitors were immediatly set to 59hz. While my second monitor's driver auto-installed, my main 144hz monitor didn't recognize and was labelled "Generic PnP Monitor" in device manager and driver info. When I tried to change my VG248QE to anything above 59hz including 60hz it would either freak out or all the pixels would just go pink.


I tried downloading the Windows 7 and Windows 8 drivers online from ASUS for the monitor but it did nothing (Windows 8.1+ didn't require/use install disk and don't have online downloads as they are meant to auto-recognize and install the monitor drivers.)


I ended up manually uninstalling and installing every version of AMD drivers until I got to 16.12.2 which while it still doesn't auto-install my monitor's drivers I can at least use 144hz most of the time with only a few glitches. But now things like skype, netflix, certain screen recorders, etc. completely kill off my monitor and I have to restart my PC. If I unplug the monitor and plug it back in it also freaks out and I have to restart. My drivers may also now be conflicting with latest OBS Studio updates (16.12.2 AMD Drivers)


It's worth mentioning that Radeon Settings recognizes my VG248QE monitor in the "Display" tab labeled as "VG248, DVI-I (AMD Radeon HD 7700 Series)" and "VG248, DVI-D (AMD Radeon HD 7700 Series)". But my device manager/Windows doesn't recognize my VG248QE as anything other than Generic PnP Monitor. Also Radeon Settings couldn't set custom resolutions at all on any of the versions I tried and if Eyefinity gets enabled my VG248QE completely stops responding until the monitors are set back to individual.


--System Information--

AMD Overview

Radeon Software Version - 16.12.2

Radeon Software Edition - Crimson ReLive

Graphics Chipset - AMD Radeon HD 7700 Series

Memory Size - 1024 MB

Memory Type - GDDR5

Core Clock - 1020 MHz

Windows Version - Windows 10 (64 bit)

System Memory - 12 GB

CPU Type - AMD FX(tm)-8300 Eight-Core Processor



Radeon Settings Version - 2016.1223.1240.22785

Driver Packaging Version - 16.50.2011-161223a-310011C

Provider - Advanced Micro Devices, Inc.

2D Driver Version -

Direct3D® Version -

OpenGL® Version -

OpenCL™ Version - 21.19.407.0

AMD Mantle Version -

AMD Mantle API Version - 102400

AMD Audio Driver Version -

Vulkan™ Driver Version - 1.4.1

Vulkan™ API Version - 1.0.30


Hardware AMD Radeon HD 7700 Series (Primary)

Graphics Card Manufacturer - Powered by AMD

Graphics Chipset - AMD Radeon HD 7700 Series

Device ID - 683D

Vendor ID - 1002

SubSystem ID - 8760

SubSystem Vendor ID - 1043

Revision ID - 00

Bus Type - PCI Express 3.0

Current Bus Settings - PCI Express 2.0 x16

BIOS Version -

BIOS Part Number - 113-AD40500-118

BIOS Date - 2013/05/20 04:09

Memory Size - 1024 MB

Memory Type - GDDR5

Memory Clock - 1150 MHz

Core Clock - 1020 MHz

Total Memory Bandwidth - 73 GByte/s

2D Driver File Path - /REGISTRY/MACHINE/SYSTEM/ControlSet001/Control/Class/{4d36e968-e325-11ce-bfc1-08002be10318}/0000