17.7.1 - Partial Installation Only. What could be wrong?

Hello everyone.

 

So, I decided to update from 17.5.2 to 17.7.1 so Windows would stop trying to update my Radeon drivers for reasons beyond me.  I had no issues before, but with this update things have been... less than ideal.  I've attempted this a number of times already but the results are the same - a partial installation with mentions of an "Error 1603" and the need to restart my computer.

 

The first two times I attempted to install regularly, the third and fourth time I had my Avast shields disabled for 10 minutes - the third attempt resulting in the need to reboot and things looking like they would succeed... but after the restart and its attempts to finish, after it sets everything back up (display adaptors, settings, etc) it asks if I want to install ReLive - which I had before.  I hit install but after a few seconds it gives me the message with Error 1603 once again for Radeon.  The fourth attempt was met with the same success as the first two.

 

 

I tried again earlier with similar success as the third time - this time thinking with Avast's shields disabled until I activated them would do the trick, as well as hitting Clean Install.  It goes well until it mentions ReLive.  After that, it gives me the same partial installation message and error.  And checking my AMD app on my desktop says my version is 17.7.1 - and with this last attempt I had a notification saying ReLive was installed successfully and could be activated in the settings.  However, looking at the Driver Detector says it's partially installed and gives me the option to install either 17.4.2 (recommended) or 17.7.1 (optional).

 

Is there anything I can do to resolve this?  I don't want to have to reinstall anything crucial because of this strange issue.  Has anyone else had problems updating?